import Foundation
let pattern = #"^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)