# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*"
test_str = ("some_txt\n"
" # → some_txt\n"
"[info1]some_txt\n"
" # → some_txt\n"
"[info1][info2] some_text\n"
" # → some_txt\n"
"[info1][info2] some_text_with_[___]_abc\n"
" # → some_text_with_[___]_abc\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.