#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*"
Local $sString = "some_txt" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1]some_txt" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1][info2] some_text" & @CRLF & _
" # → some_txt" & @CRLF & _
"[info1][info2] some_text_with_[___]_abc" & @CRLF & _
" # → some_text_with_[___]_abc" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)