package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*`)
var str = `some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}