#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?)([\s:]+)?{([\s\S].*)?.$"
Local $sString = "key:{value}" & @CRLF & _
"key:{valu{0}e}" & @CRLF & _
"key:{valu" & @CRLF & _
"{0}e}" & @CRLF & _
"key: {val-u{0}e}" & @CRLF & _
"key: {val__[!]" & @CRLF & _
"-u{0}{1}e}"
Local $sSubst = "$1,$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)