$re = '/^(.*?)([\s:]+)?{([\s\S].*)?.$/m';
$str = 'key:{value}
key:{valu{0}e}
key:{valu
{0}e}
key: {val-u{0}e}
key: {val__[!]
-u{0}{1}e}';
$subst = "$1,$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;