import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)([\\s:]+)?\\{([\\s\\S].*)?.$";
final String string = "key:{value}\n"
+ "key:{valu{0}e}\n"
+ "key:{valu\n"
+ "{0}e}\n"
+ "key: {val-u{0}e}\n"
+ "key: {val__[!]\n"
+ "-u{0}{1}e}";
final String subst = "$1,$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}