use strict;
my $str = 'key:{value}
key:{valu{0}e}
key:{valu
{0}e}
key: {val-u{0}e}
key: {val__[!]
-u{0}{1}e}';
my $regex = qr/^(.*?)([\s:]+)?{([\s\S].*)?.$/mp;
my $subst = '$1,$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";