package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)([\s:]+)?{([\s\S].*)?.$`)
var str = `key:{value}
key:{valu{0}e}
key:{valu
{0}e}
key: {val-u{0}e}
key: {val__[!]
-u{0}{1}e}`
var substitution = "$1,$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}