const regex = /^(.*?)([\s:]+)?{([\s\S].*)?.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)([\\s:]+)?{([\\s\\S].*)?.$', 'gm')
const str = `key:{value}
key:{valu{0}e}
key:{valu
{0}e}
key: {val-u{0}e}
key: {val__[!]
-u{0}{1}e}`;
const subst = `$1,$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);