using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*-11-03-2015-.*_470123023_META\.xml";
string input = @"wehansen-11-03-2015-09-35-12_470123023_META.xml";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}