re = /.*-11-03-2015-.*_470123023_META\.xml/
str = 'wehansen-11-03-2015-09-35-12_470123023_META.xml'
# Print the match result
str.match(re) do |match|
puts match.to_s
end