import re
regex = re.compile(r".*-11-03-2015-.*_470123023_META\.xml")
test_str = "wehansen-11-03-2015-09-35-12_470123023_META.xml"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")