$re = '/.*-11-03-2015-.*_470123023_META\.xml/';
$str = 'wehansen-11-03-2015-09-35-12_470123023_META.xml';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);