# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/test\.([^\.]+)\.com/www.$1.com/g;t' <<< "test.example.com
test.memberpress.com
www.affiliateroyale.com
test.google.com
"