// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"test\.([^\.]+)\.com").unwrap();
let string = "test.example.com
test.memberpress.com
www.affiliateroyale.com
test.google.com
";
let substitution = "www.$1.com";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}