$re = '/test\.([^\.]+)\.com/';
$str = 'test.example.com
test.memberpress.com
www.affiliateroyale.com
test.google.com
';
$subst = "www.$1.com";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;