#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "test\.([^\.]+)\.com"
Local $sString = "test.example.com" & @CRLF & _
"test.memberpress.com" & @CRLF & _
"www.affiliateroyale.com" & @CRLF & _
"test.google.com" & @CRLF & _
""
Local $sSubst = "www.$1.com"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)