import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test\\.([^\\.]+)\\.com";
final String string = "test.example.com\n"
+ "test.memberpress.com\n"
+ "www.affiliateroyale.com\n"
+ "test.google.com\n";
final String subst = "www.$1.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}