re = /test\.([^\.]+)\.com/
str = 'test.example.com
test.memberpress.com
www.affiliateroyale.com
test.google.com
'
subst = 'www.$1.com'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result