const regex = /"[^"]?""/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]?""', 'gm')
const str = `1 "many word " "many word" "many word "
2 "many word " " <-Error quotation
3 "many word " "many word " " many word " " many word " " <-Error quotation
4 """ but this quotation not match
5 "\\"" this is not match
6 " aasd \\" " " <-Error quotation \\"
only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}