import Foundation
let pattern = #""[^"]?"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 "many word " "many word" "many word "
2 "many word " " <-Error quotation
3 "many word " "many word " " many word " " many word " " <-Error quotation
4 """ but this quotation not match
5 "\"" this is not match
6 " aasd \" " " <-Error quotation \"
only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)