re = /"[^"]?""/m
str = '1 "many word " "many word" "many word "
2 "many word " " <-Error quotation
3 "many word " "many word " " many word " " many word " " <-Error quotation
4 """ but this quotation not match
5 "\\"" this is not match
6 " aasd \\" " " <-Error quotation \\"
only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end