use strict;
my $str = '1 "many word " "many word" "many word "
2 "many word " " <-Error quotation
3 "many word " "many word " " many word " " many word " " <-Error quotation
4 """ but this quotation not match
5 "\\"" this is not match
6 " aasd \\" " " <-Error quotation \\"
only line 2 3 6 have an error quotation i need to find a line have an error quotation by regex';
my $regex = qr/"[^"]?""/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}