#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^@fortawesome\/.+svg-icons$"
Local $sString = "@fortawesome/free-solid-svg-icons/faCalendar" & @CRLF & _
"@fortawesome/pro-solid-svg-icons" & @CRLF & _
"@fortawesome/pro-light-svg-icons" & @CRLF & _
"@fortawesome/react-native-fontawesome"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")