re = /^@fortawesome\/.+svg-icons$/m
str = '@fortawesome/free-solid-svg-icons/faCalendar
@fortawesome/pro-solid-svg-icons
@fortawesome/pro-light-svg-icons
@fortawesome/react-native-fontawesome'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end