// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^@fortawesome\/.+svg-icons$").unwrap();
let string = "@fortawesome/free-solid-svg-icons/faCalendar
@fortawesome/pro-solid-svg-icons
@fortawesome/pro-light-svg-icons
@fortawesome/react-native-fontawesome";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}