import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^@fortawesome\\/.+svg-icons$";
final String string = "@fortawesome/free-solid-svg-icons/faCalendar\n"
+ "@fortawesome/pro-solid-svg-icons\n"
+ "@fortawesome/pro-light-svg-icons\n"
+ "@fortawesome/react-native-fontawesome";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}