package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^@fortawesome\/.+svg-icons$`)
var str = `@fortawesome/free-solid-svg-icons/faCalendar
@fortawesome/pro-solid-svg-icons
@fortawesome/pro-light-svg-icons
@fortawesome/react-native-fontawesome`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}