const regex = /&(.*?)=(?:\$(\w+){)?([^&\z}]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&(.*?)=(?:\\$(\\w+){)?([^&\\z}]*)', 'g')
const str = `ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=\$PARAM{RESPONSE_MESSAGE}
&ERRORCODE=\$PARAM{ACK_ERRORCODE}&TOTALTIME=\$PARAM{ACK_TOTALTIME}&OVERHEADTIME=\$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=\$PARAM{REQUESTID}&SRCALARMID=\$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=\$PARAM{ACK_ERRORLIST}&USERMESSAGE=\$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=\$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=\$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=\$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=\$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=\$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}