re = /&(.*?)=(?:\$(\w+){)?([^&\z}]*)/
str = 'ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=$PARAM{RESPONSE_MESSAGE}
&ERRORCODE=$PARAM{ACK_ERRORCODE}&TOTALTIME=$PARAM{ACK_TOTALTIME}&OVERHEADTIME=$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=$PARAM{REQUESTID}&SRCALARMID=$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=$PARAM{ACK_ERRORLIST}&USERMESSAGE=$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end