$re = '/&(.*?)=(?:\$(\w+){)?([^&\z}]*)/';
$str = 'ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=$PARAM{RESPONSE_MESSAGE}
&ERRORCODE=$PARAM{ACK_ERRORCODE}&TOTALTIME=$PARAM{ACK_TOTALTIME}&OVERHEADTIME=$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=$PARAM{REQUESTID}&SRCALARMID=$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=$PARAM{ACK_ERRORLIST}&USERMESSAGE=$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);