import re
regex = re.compile(r"&(.*?)=(?:\$(\w+){)?([^&\z}]*)")
test_str = ("ResolvePublishAlarmInfoAck#tibco.AG.XML?RESOLVEPUBLISHALARMINFOACK_XML:=$PARAM{RESPONSE_MESSAGE}\n"
"&ERRORCODE=$PARAM{ACK_ERRORCODE}&TOTALTIME=$PARAM{ACK_TOTALTIME}&OVERHEADTIME=$PARAM{ACK_OVERHEADTIME}&SRCSYSTEM=RESOLVE&REQUESTID=$PARAM{REQUESTID}&SRCALARMID=$PARAM{ACK_ALARMID_SRCALARMID}&ERRORLIST=$PARAM{ACK_ERRORLIST}&USERMESSAGE=$PARAM{ACK_USERMESSAGE}&ERRORMESSAGE=$PARAM{ACK_ERRORMESSAGE}&SEVERITYLEVEL=$PARAM{ACK_SEVERITYLEVEL}&HOSTERRORLISTID=$PARAM{ACK_HOSTERRORLISTID}&TRANSACTIONSTATUS=$PARAM{ACK_TRANSACTIONSTATUS}&SRCSERVERNAME=$PARAM{ACK_ALARMID_SRCSERVERNAME}&COMPLETEDTIMESTAMP=CURTIME")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")