#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]([a-zA-Z]|[0-9])+"
Local $sString = "ab10239812049812409124809AWRLAWKTJAWLTKAWJt" & @CRLF & _
"04234234230492384" & @CRLF & _
"BBBBBBBaaaaaaaaaaaaaaaaa34242342344" & @CRLF & _
"a1b2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")