$re = '/[a-zA-Z]([a-zA-Z]|[0-9])+/';
$str = 'ab10239812049812409124809AWRLAWKTJAWLTKAWJt
04234234230492384
BBBBBBBaaaaaaaaaaaaaaaaa34242342344
a1b2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);