// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z]([a-zA-Z]|[0-9])+").unwrap();
let string = "ab10239812049812409124809AWRLAWKTJAWLTKAWJt
04234234230492384
BBBBBBBaaaaaaaaaaaaaaaaa34242342344
a1b2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}