import Foundation
let pattern = #"[a-zA-Z]([a-zA-Z]|[0-9])+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ab10239812049812409124809AWRLAWKTJAWLTKAWJt
04234234230492384
BBBBBBBaaaaaaaaaaaaaaaaa34242342344
a1b2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)