import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]([a-zA-Z]|[0-9])+";
final String string = "ab10239812049812409124809AWRLAWKTJAWLTKAWJt\n"
+ "04234234230492384\n"
+ "BBBBBBBaaaaaaaaaaaaaaaaa34242342344\n"
+ "a1b2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}