#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^,]+(?:,[^,]+)*$"
Local $sString = "求一个以,分割的字符串,并且结尾不能是逗号的正则表达式" & @CRLF & _
"sldfjkf,jsdlfkjf,jsdlkfjdfk," & @CRLF & _
"jsdlkfjdf,7987,osidfj,sdkfjk" & @CRLF & _
"快递费接口了多发,skdfjkldf,ksldfjdfk,789jk" & @CRLF & _
"kkjsfk,肯德基弗兰克,skldfj," & @CRLF & _
",,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")