const regex = /^[^,]+(?:,[^,]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^,]+(?:,[^,]+)*$', 'gm')
const str = `求一个以,分割的字符串,并且结尾不能是逗号的正则表达式
sldfjkf,jsdlfkjf,jsdlkfjdfk,
jsdlkfjdf,7987,osidfj,sdkfjk
快递费接口了多发,skdfjkldf,ksldfjdfk,789jk
kkjsfk,肯德基弗兰克,skldfj,
,,,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}