package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^,]+(?:,[^,]+)*$`)
var str = `求一个以,分割的字符串,并且结尾不能是逗号的正则表达式
sldfjkf,jsdlfkjf,jsdlkfjdfk,
jsdlkfjdf,7987,osidfj,sdkfjk
快递费接口了多发,skdfjkldf,ksldfjdfk,789jk
kkjsfk,肯德基弗兰克,skldfj,
,,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}