use strict;
my $str = '求一个以,分割的字符串,并且结尾不能是逗号的正则表达式
sldfjkf,jsdlfkjf,jsdlkfjdfk,
jsdlkfjdf,7987,osidfj,sdkfjk
快递费接口了多发,skdfjkldf,ksldfjdfk,789jk
kkjsfk,肯德基弗兰克,skldfj,
,,,,';
my $regex = qr/^[^,]+(?:,[^,]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}