$re = '/^[^,]+(?:,[^,]+)*$/m';
$str = '求一个以,分割的字符串,并且结尾不能是逗号的正则表达式
sldfjkf,jsdlfkjf,jsdlkfjdfk,
jsdlkfjdf,7987,osidfj,sdkfjk
快递费接口了多发,skdfjkldf,ksldfjdfk,789jk
kkjsfk,肯德基弗兰克,skldfj,
,,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);