using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^,]+(?:,[^,]+)*$";
string input = @"求一个以,分割的字符串,并且结尾不能是逗号的正则表达式
sldfjkf,jsdlfkjf,jsdlkfjdfk,
jsdlkfjdf,7987,osidfj,sdkfjk
快递费接口了多发,skdfjkldf,ksldfjdfk,789jk
kkjsfk,肯德基弗兰克,skldfj,
,,,,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}