using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s(?:-\s)?(.*)";
string input = @"PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}