const regex = /(\d+)\s(?:-\s)?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s(?:-\\s)?(.*)', 'gm')
const str = `PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}