// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\s(?:-\s)?(.*)").unwrap();
let string = "PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}