re = /(\d+)\s(?:-\s)?(.*)/m
str = 'PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end