$re = '/(\d+)\s(?:-\s)?(.*)/m';
$str = 'PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);