package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s(?:-\s)?(.*)`)
var str = `PO 94961,tax
PO 94961,MAT 3x5 gray
PO 94961,Replace Huck Towels 15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}